Evaluating High-Density Multimedia Streaming and Roaming in a Wireless Network

Configuration

 

CAPsMAN:

 

/interface bridge

add name=bridge1

/interface bridge port

add bridge=bridge1 interface=ether1

add bridge=bridge1 interface=ether10

add bridge=bridge1 interface=ether5

add bridge=bridge1 interface=ether2

add bridge=bridge1 interface=ether3

add bridge=bridge1 interface=ether4

add bridge=bridge1 interface=ether6

add bridge=bridge1 interface=ether7

add bridge=bridge1 interface=ether8

add bridge=bridge1 interface=ether9

/ip dhcp-client

add interface=bridge1

/interface wifiwave2 channel

add band=2ghz-ax disabled=no frequency=2412 name=channel1-2.4GHz skip-dfs-channels=all width=20mhz

add band=2ghz-ax disabled=no frequency=2437 name=channel6-2.4GHz skip-dfs-channels=all width=20mhz

add band=2ghz-ax disabled=no frequency=2462 name=channel11-2.4GHz skip-dfs-channels=all width=20mhz

add band=5ghz-ax disabled=no frequency=5180 name=5GHz-5180 width=20/40/80mhz

add band=5ghz-ax disabled=no frequency=5745 name=5GHz-5745 width=20/40/80mhz

add band=5ghz-ax disabled=no frequency=5500 name=5GHz-5500 width=20/40/80mhz

add band=5ghz-ax disabled=no name="5GHz auto" skip-dfs-channels=all width=20/40/80mhz

/interface wifiwave2 datapath

add bridge=bridge1 client-isolation=yes disabled=no name=datapath-VLAN1010 vlan-id=1010

add bridge=bridge1 client-isolation=yes disabled=no name=datapath1

/interface wifiwave2 configuration

add channel=5GHz-5180 datapath=datapath-VLAN1010 disabled=no mode=ap name="cfg1-5180" ssid="MIKROTIK AX TEST"

add channel=channel1-2.4GHz datapath=datapath-VLAN1010 disabled=no mode=ap name="cfg4-2,4Ghz ch.1" ssid="MIKROTIK AX TEST"

add channel=channel6-2.4GHz datapath=datapath-VLAN1010 disabled=no mode=ap name="cfg5-2,4Ghz ch.6" ssid="MIKROTIK AX TEST"

add channel=channel11-2.4GHz datapath=datapath-VLAN1010 disabled=no mode=ap name="cfg6-2,4Ghz ch.11" ssid="MIKROTIK AX TEST"

add channel=5GHz-5745 datapath=datapath-VLAN1010 disabled=no mode=ap name="cfg1-5745" ssid="MIKROTIK AX TEST"

add channel=5GHz-5500 datapath=datapath-VLAN1010 disabled=no mode=ap name="cfg1-5500" ssid="MIKROTIK AX TEST"

/interface wifiwave2 security

add authentication-types=wpa2-psk disabled=no ft=yes ft-over-ds=yes management-protection=disabled name=sec1_Classroom

add authentication-types=wpa2-psk disabled=no ft=yes ft-over-ds=yes management-protection=disabled name=sec2_STAFF

add authentication-types=wpa2-psk disabled=no ft=yes ft-over-ds=yes management-protection=disabled name="sec3_MIKROTIK AX TEST"

/interface wifiwave2 configuration

add channel=5GHz-5180 datapath=datapath1 disabled=no mode=ap name="cfg1-5180 Classrooms" security=sec1_Classroom ssid=Classrooms

add channel=5GHz-5180 datapath=datapath1 disabled=no mode=ap name="cfg3-5180 STAFF" security=sec2_STAFF ssid=STAFF

add channel=channel1-2.4GHz datapath=datapath1 disabled=no mode=ap name="cfg7-2,4GHz ch1 Classrooms" \

security=sec1_Classroom ssid=Classrooms

add channel=channel6-2.4GHz datapath=datapath1 disabled=no mode=ap name="cfg8-2,4GHz ch6 Classrooms" \

security=sec1_Classroom ssid=Classrooms

add channel=channel11-2.4GHz datapath=datapath1 disabled=no mode=ap name="cfg9-2,4GHz ch11 Classrooms" \

security=sec1_Classroom ssid=Classrooms

add channel=channel1-2.4GHz datapath=datapath1 disabled=no mode=ap name="cfg10-2,4GHz ch1 STAFF" security=sec2_STAFF ssid=STAFF

add channel=channel6-2.4GHz datapath=datapath1 disabled=no mode=ap name="cfg11-2,4GHz ch6 STAFF" security=sec2_STAFF ssid=STAFF

add channel=channel11-2.4GHz datapath=datapath1 disabled=no mode=ap name="cfg12-2,4GHz ch11 STAFF" security=sec2_STAFF ssid=STAFF

add channel=5GHz-5745 datapath=datapath1 disabled=no mode=ap name="cfg1-5745 Classrooms" security=sec1_Classroom ssid=Classrooms

add channel=5GHz-5500 datapath=datapath1 disabled=no mode=ap name="cfg1-5500 Classrooms" security=sec1_Classroom ssid=Classrooms

add channel=5GHz-5745 datapath=datapath1 disabled=no mode=ap name="cfg3-5745 STAFF" security=sec2_STAFF ssid=STAFF

add channel=5GHz-5500 datapath=datapath1 disabled=no mode=ap name="cfg3-5500 STAFF" security=sec2_STAFF ssid=STAFF

/interface wifiwave2 capsman

set enabled=yes interfaces=bridge1 package-path="" require-peer-certificate=no upgrade-policy=none

/interface wifiwave2 provisioning

add action=create-dynamic-enabled comment="5GHz 5180" disabled=no identity-regexp=5180 master-configuration="cfg1-5180" \

name-format=5GHz-%I_ slave-configurations="cfg1-5180 Classrooms,cfg3-5180 STAFF" supported-bands=5ghz-ax

add action=create-dynamic-enabled comment="5GHz 5745" disabled=no identity-regexp=5745 master-configuration="cfg1-5745" \

name-format=5GHz-%I_ slave-configurations="cfg1-5745 Classrooms,cfg3-5745 STAFF" supported-bands=5ghz-ax

add action=create-dynamic-enabled comment="5GHz 5500" disabled=no identity-regexp=5500 master-configuration="cfg1-5500" \

name-format=5GHz-%I_ slave-configurations="cfg1-5500 Classrooms,cfg3-5500 STAFF" supported-bands=5ghz-ax

add action=create-dynamic-enabled comment="2.4Ghz ch1 2412" disabled=no identity-regexp=ch1 \

master-configuration="cfg4-2,4Ghz ch.1" \

name-format=2.4GHz-%I_ slave-configurations="cfg7-2,4GHz ch1 Classrooms,cfg10-2,4GHz ch1 STAFF" supported-bands=2ghz-ax

add action=create-dynamic-enabled comment="2.4Ghz ch6 2437" disabled=no identity-regexp=ch2 master-configuration="cfg5-2,4Ghz ch.6" \

 name-format=2.4GHz-%I_ slave-configurations="cfg8-2,4GHz ch6 Classrooms,cfg11-2,4GHz ch6 STAFF" supported-bands=2ghz-ax

add action=create-dynamic-enabled comment="2.4Ghz ch11 2462" disabled=no identity-regexp=ch3 master-configuration="cfg6-2,4Ghz ch.11" \

 name-format=2.4GHz-%I_ slave-configurations="cfg9-2,4GHz ch11 Classrooms,cfg12-2,4GHz ch11 STAFF" supported-bands=2ghz-ax

 

Cap 1 - cAP-106 ch1 5180

/interface bridge

add name=bridge1

/interface bridge port

add bridge=bridge1 interface=ether1

add bridge=bridge1 interface=ether2

/ip dhcp-client

add interface=bridge1

/interface wifiwave2 datapath

add bridge=bridge1 disabled=no name=capdp

/interface wifiwave2

set [ find default-name=wifi1 ] configuration.manager=capsman .mode=ap   datapath=capdp disabled=no

set [ find default-name=wifi2 ] configuration.manager=capsman .mode=ap datapath=capdp disabled=no

/interface wifiwave2 cap

set discovery-interfaces=bridge1 enabled=yes slaves-datapath=capdp

set name="cAP-106 ch1 5180"

 

CAP2 - cAP-105 ch3 5745

/interface bridge

add name=bridge1

/interface bridge port

add bridge=bridge1 interface=ether1

add bridge=bridge1 interface=ether2

set discovery-interfaces=bridge1 enabled=yes slaves-datapath=capdp

/ip dhcp-client

add interface=bridge1

/interface wifiwave2 datapath

add bridge=bridge1 disabled=no name=capdp

/interface wifiwave2

set [ find default-name=wifi1 ] configuration.manager=capsman .mode=ap  datapath=capdp disabled=no

set [ find default-name=wifi2 ] configuration.manager=capsman .mode=ap  datapath=capdp disabled=no

/interface bridge port

add bridge=bridge1 interface=ether1

add bridge=bridge1 interface=ether2

/interface wifiwave2 cap

/system identity

set name="cAP-105 ch3 5745"